Restauration d'un téléviseur Philips 17TX170A / 88 de 1957

Echanges d’informations et d’astuces techniques dédiées à la télévision et à la vidéo anciennes.

Modérateur: jrob

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Myke » Lun 24 Aoû 2015 17h47

Bonjour,

Y a t il des logiciels sous linux pour faire la même chose avec la carte graphique?

Cordialement.
Myke
 
Messages: 385
Inscription: Dim 6 Jan 2008 23h23
Localisation: Libramont, Belgique

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Domi-Niaque » Lun 24 Aoû 2015 18h17

Myke a écrit:Bonjour,

Y a t il des logiciels sous linux pour faire la même chose avec la carte graphique?

Cordialement.


C'est Xorg qui s'occupe de l'affichage, mais il faut avoir Xrandr pour configurer.
RFL5933
Troc:
Sauf mention contraire, prix franco de port
Règlement: PayPal ou chèque à mon ordre
Domi-Niaque
 
Messages: 1271
Inscription: Lun 21 Déc 2009 19h20
Localisation: Sud-Est de l'IdF

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Myke » Lun 24 Aoû 2015 18h45

Domi-Niaque a écrit:
Myke a écrit:Bonjour,

Y a t il des logiciels sous linux pour faire la même chose avec la carte graphique?

Cordialement.


C'est Xorg qui s'occupe de l'affichage, mais il faut avoir Xrandr pour configurer.


Ok, j'ai Xrandr, mais quelle est la façon de procéder si on veut par exemple générer du 819 ou 625 lignes pour nos anciens TV?

Par avance, merci.

Cordialement.
Myke
 
Messages: 385
Inscription: Dim 6 Jan 2008 23h23
Localisation: Libramont, Belgique

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Domi-Niaque » Lun 24 Aoû 2015 18h54

Pour paramétrer les affichages, il faut éditer les modelines dans le fichier X11, comme indiqué ici:
http://doc.ubuntu-fr.org/configurer_son_ecran_old
Ce qui est bien évidemment moins pratique que via un soft en interface graphique, style Powerstrip.
RFL5933
Troc:
Sauf mention contraire, prix franco de port
Règlement: PayPal ou chèque à mon ordre
Domi-Niaque
 
Messages: 1271
Inscription: Lun 21 Déc 2009 19h20
Localisation: Sud-Est de l'IdF

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Mister DCE » Mer 26 Aoû 2015 19h37

La suite de l'histoire.

Je vais temporairement abandonner l'idée de récupérer le signal VGA pour utiliser ce téléviseur. Il y a deux problèmes qui font obstacle:

Le premier c'est la CAG semi-désactivée. En fait c'est à cause d'elle que mon préampli vidéo n'est pas totalement effectif, quand je rajoute du gain, la CAG diminue le signal et vice-versa.

Le deuxième c'est que la variation automatique de la CAG a une incidence sur la synchro horizontale de l'image. Si en S-Video c'est discret, en VGA vers 625 lignes l'image est ondulée, et au mieux les ondulations sont fixes ce qui donne ceci:

WP_20150824_003b.jpg

En 819 Lignes, ce sont les mêmes ondulations mais qui oscillent à des fréquences beaucoup plus élevées ce qui rend l'image illisible et curieusement dans ce mode la CAG obscurcit encore d'avantage l'image ce qui provoque des pertes de synchros verticales.

Donc maintenant j'exploite le téléviseur via le s-video de mon laptop. J'ai galéré car partout je lisais qu'il fallait d'abord allumer la tv et ensuite le laptop pour la détection de l'écran. En fait ici, sur ce Travelmate 4000 (le bios de l'aspire 1700 est définitevment HS) c'est l'inverse: il faut hot-plugger, brancher le téléviseur à chaud sur le laptop pendant le boot pour que ce damné port s-video daigne fonctionner.
De plus les drivers de cette carte radeon sont très malfoutus. Parfois la télévision est active, l'icone TV est "déconnectable" tout en mentionnant "pas de signal" alors que tout fonctionne bien. Bref, on va dire que j'ai contourné ce problème.

Malgré tout, l'image manque toujours de puissance, les blancs sont trop gris et ce n'est pas le CRT car celui-ci est encore super péchu, j'aimerais trafiquer cette CAG pour la bloquer définitivement dans un mode où elle n'essaie pas d'atténuer l'instensité du signal.

Avec le bouton de contraste en façade on peut observer que lorsqu'on le met d'un coup à fond, l'image est nickel pendant une demi seconde, le temps que la CAG ne fasse descendre l'intensité de l'image.

Lorsque c'est avec le préampli que je booste le signal, la CAG part en sucette, atténue et parfois décroche, ce qui fait flasher l'écran puisque pendant le temps du décrochage, j'ai une image hyper puissante. Ca doit d'ailleurs être mauvais, autant pour le tube, que pour les yeux sans parler des PL83 et autres. Lorsque j'observais une image baveuse c'est en fait car j'applique déjà à ce moment là un gain beaucoup trop puissant mais qui semblait ne pas se manifester à cause de cette CAG.

Il me faut donc proprement bloquer cette maudite commande automatique de gain dans une position ou elle n'atténue pas le signal.
Dernière édition par Mister DCE le Mer 26 Aoû 2015 20h35, édité 1 fois.
Mister DCE
 
Messages: 97
Inscription: Ven 19 Juin 2015 22h43

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Domi-Niaque » Mer 26 Aoû 2015 19h52

Si tu peux, essaie avec différentes cartes ATI et en dernier recours, passe chez Nvidia (série GF7).
As-tu regardé mes précédents posts ?
RFL5933
Troc:
Sauf mention contraire, prix franco de port
Règlement: PayPal ou chèque à mon ordre
Domi-Niaque
 
Messages: 1271
Inscription: Lun 21 Déc 2009 19h20
Localisation: Sud-Est de l'IdF

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Mister DCE » Mer 26 Aoû 2015 20h33

Oui bien sûr ! :wink:
HydraVision est un chouette soft bien pratique que je vais garder sous la main. Il ne permet cependant pas de contourner les problèmes relatifs au drivers ati radeon 9700 Mobility. Pour le 819 lignes j'ai suivi tes instructions avec ta version de powerstrip mais je ne suis pas parvenu à avoir un résultat valable à cause des soucis que je mentionne plus haut.

Je n'ai malheureusement pas de laptop pourvu de GeForce7. J'ai bien un rack avec une 7300GT mais il est intransportable et fait un boucan d'enfer. Maintenant je suis sûr que ce petit laptop devrait suffire mais il me faut d'abord résoudre ce problème de CAG, c'est cela qui altère en amont la qualité de mon image quelle que soit la source (dvd, s-video, VGA, ...)
Mister DCE
 
Messages: 97
Inscription: Ven 19 Juin 2015 22h43

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Domi-Niaque » Mer 26 Aoû 2015 21h08

Si je comprends bien, tu veux inhiber le CAG ?
Regarde sur ce site (très bien documenté), sûrement trouveras-tu la réponse à ton souçi.
http://dede92dubois.free.fr/page2.html
Je pense que la façon dont les signaux soient mélangés dans le cas du VGA pourrait jouer sur l'instabilité que tu observes. :?:
Si tu faisais l'interface que j'ai faite, peut-être verras-tu une amélioration. :wink:
RFL5933
Troc:
Sauf mention contraire, prix franco de port
Règlement: PayPal ou chèque à mon ordre
Domi-Niaque
 
Messages: 1271
Inscription: Lun 21 Déc 2009 19h20
Localisation: Sud-Est de l'IdF

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Mister DCE » Mer 26 Aoû 2015 22h59

J'aimerais bien mais je n'ai pas le matoz qu'il faut pour créer les circuits imprimés :-/

EDIT: mais je suis quasiment sûr que sans l'instabilité du signal dûe à la CAG, les résultats issus du VGA seraient au point. Ce qui me pousse à penser cela c'est que j'ai réussi à avoir une image bien nette à la géométrie parfaite provenant du VGA, mais tout part en vrille aux moindres changements de luminosité -> perte de synchro verticale, horizontale, des symptômes finalement proches de ceux que j'avais au tout début de la restauration, avant l'injection directe, avant la désactivation partielle de cette CAG.

Au lieu de tenter une désactivation il faudrait la neutraliser et la bloquer à une valeur donnée. Peut-être en modifiant au niveau de la détection de l'intensité du signal plutôt qu'une bricole à la commande du gain ?
Dernière édition par Mister DCE le Sam 29 Aoû 2015 14h26, édité 1 fois.
Mister DCE
 
Messages: 97
Inscription: Ven 19 Juin 2015 22h43

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Domi-Niaque » Sam 29 Aoû 2015 11h13

J'ai eu ton mail ce matin.
Très sympa l'idée de ton site http://www.actingmachines.com/ pour le cinéma, comme le fait également notre forumeur JL.GENDRON.
J'ai 2 bouquins des 50's sur le fonctionnement des tv de cette époque, je regarderais plus en détail s'il est évoqué le sujet du CAG et je te scannerais selon ce que je vais trouver.
Je commence aussi à réfléchir "in my head" à une version "optocouplée" de mon interface VGA qui serait prévue pour se mettre directement dans l'appareil et dont la luminance et la synchro seraient séparées pour être envoyées directement vers leurs étages respectifs.
RFL5933
Troc:
Sauf mention contraire, prix franco de port
Règlement: PayPal ou chèque à mon ordre
Domi-Niaque
 
Messages: 1271
Inscription: Lun 21 Déc 2009 19h20
Localisation: Sud-Est de l'IdF

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Mister DCE » Sam 29 Aoû 2015 22h18

Je te remercie d'avance pour cette recherche :)
Mister DCE
 
Messages: 97
Inscription: Ven 19 Juin 2015 22h43

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Domi-Niaque » Dim 30 Aoû 2015 21h13

Existe-t-il des optocoupleurs ayant une bande passante d'au moins 10 MHz ?
Car l'idée d'une interface optocouplée me plaît bien pour les tv à "châssis chaud", mais encore faut-il trouver des composants adaptés pour cette fréquence.
RFL5933
Troc:
Sauf mention contraire, prix franco de port
Règlement: PayPal ou chèque à mon ordre
Domi-Niaque
 
Messages: 1271
Inscription: Lun 21 Déc 2009 19h20
Localisation: Sud-Est de l'IdF

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Mister DCE » Lun 31 Aoû 2015 21h28

Victoire !!!
Afin d'avoir des précisions sur le préampli et son intégration, j'ai directement contacté celui qui l'a réalisé et mis les plans à disposition sur cfp-radio. Grâce à cette précieuse aide la source du problème est désormais identifiée:

Ce téléviseur étant multistandard il y a des commutations entre la PL83 et la ECC85 à proximité afin de moduler le signal soit en positif ou en négatif. Pour permettre cette inversion il y a dans la cathode de la PL83 2 résistances non découplées, montage déphaseur. Le signal vidéo est donc injecté entre la grille et la cathode de la PL83 et non pas entre la grille et la masse !! La solution : découpler la cathode de la PL83 afin de retrouver un gain normal avec le préampli. J'ai donc ajouté un condensateur de 470µF 25V entre la broche 3 et la masse et là ... MIRACLE :D

Pour rappel j'avais ce genre de résultat

IMG_5223b.jpg

Avec le condo de 470µF entre la cathode de la PL83 et la masse:

IMG_5224b.jpg

Et dire que j'en étais presque à tenter l'adaptation PL83 vers EL183. Enfin l'image pure que j'espérais obtenir avec cette machine!

IMG_5228b.jpg

Comme ce foutu port S-video marche une fois sur deux, notez que c'est finalement à partir du VGA que j'ai obtenu ces images. Mon petit montage VGA vers RCA monochrome côté interface hardware et côté programme, soft15Khz et Powerstrip le tout envoyant du PAL 720×576

IMG_5243b.jpg

Je suis content :-) Reste à intégrer proprement cette modification dans le châssis.

J'ai cependant encore une question à vous poser. Les bandes verticales que j'avais pris pour des salves chromas, c'est autre chose, même avec un signal sans couleurs elles restent visibles lorsque le fond est unis et clair.
Dans le cas de plans fixes cela ne se voit pas mais lorsqu'on a un film avec un scrolling horizontal lent on remarque que l'image est ondulée aux endroits des bandes. Une hypothèse ? Bobine de déflection ?
Mister DCE
 
Messages: 97
Inscription: Ven 19 Juin 2015 22h43

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar Domi-Niaque » Lun 31 Aoû 2015 22h05

Toutes nos félicitations !
Au moins, tu pourras déboucher une bonne bouteille ! :D

Je n'ai aucune idée quant aux bandes verticales, sûrement un pb de clamp ?

Tant mieux que tu l'aies réparé, tu pourras te livrer au trucage que tu sais et reprendre tes essais en 819 !

Pour ce qui est de mon idée d'interface VGA optocouplée, j'ai trouvé cet optocoupleur parmi d'autres:
http://www.produktinfo.conrad.com/datenblaetter/125000-149999/140177-da-01-en-OPTOKOPPLER_HCPL_4562_300E.pdf
RFL5933
Troc:
Sauf mention contraire, prix franco de port
Règlement: PayPal ou chèque à mon ordre
Domi-Niaque
 
Messages: 1271
Inscription: Lun 21 Déc 2009 19h20
Localisation: Sud-Est de l'IdF

Re: Restauration d'un téléviseur Philips 17TX170A / 88 de 19

Messagepar brunopif » Lun 31 Aoû 2015 23h15

Bonjour,
j'ai suivi le feuilleton tout l'été sans jamais intervenir, félicitation, l'image est parfaite manque plus que le 819 lignes par le VGA et ce serait super.
Pour vos bandes verticales qui apparaissent à gauche de l’écran, c'est un symptôme bien connu en vidéo même moderne, c'est l’œuvre d'un condensateur qui n'est plus bon aux fréquences de la vidéo, en faite vous voyez les "écho" de la synchro lignes (top ligne) qui se répercute dans la vidéo utile. le condensateur a du perdre un peu de sa capacité et la partie selfique de celui-si entraine un amortissement trop long des tops d’où leur visibilités.
Il faut maintenant trouver le fautif, il doit se trouver entre votre entrée vidéo et l'attaque du tube, c'est une capa traversée par la vidéo, en général c'est un petit chimique en TV moderne mais sur le votre, je ne sais pas.
Vous pouvez le laisser comme ça car c'est peu être une capa neuve qui peu avoir se problème.
En tout cas, bravo pour votre persévérance et pour les resultats.
Salutations
Bruno Piffret
brunopif
 
Messages: 651
Inscription: Mer 21 Juin 2006 23h06
Localisation: France

PrécédenteSuivante

Retourner vers Technique TV et vidéo

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité