Nouvelle vie pour une alim PC sauvée de la déchetterie

Place à l'inventivité et à la créativité, à lampes... ou à transistors

Modérateur: Klara

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Raffou » Mer 19 Avr 2017 20h32

Ça me semble bizarre, cela mériterait d'être approfondi pour connaître les causes de ce dysfonctionnement.
Raffou
 
Messages: 322
Inscription: Jeu 15 Mai 2014 18h17

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Hervé-P » Mer 19 Avr 2017 21h06

— Ben… avec tous les schémas fournis, je te demanderais d'essayer ! Et de voir pourquoi ça ne fonctionne pas (en intensité) avec ton dernier schéma ! Tu pourrais t'inspirer de “la perruque” de Roger33 pour essayer. Moi, j'ai essayé sur “mon” circuit-imprimé-fils de cuivre ! Je publierai des photos plus tard, quand tout sera au point.
— Cordialement !
Image Ruse de Sioux : “Ne cherchez surtout pas à compliquer des choses simples !”
Hervé-P
 
Messages: 81
Inscription: Ven 10 Fév 2017 15h36
Localisation: Sainte-Marie (Île de la Réunion)

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Raffou » Mer 19 Avr 2017 21h48

Si je ne l'ai pas encore fait c'est par ce que je n'ai aucun des composants requis en stock hormis des alimentations ATX, sinon j'aurais moi aussi expérimenté, observé les signaux à l'oscilloscope et essayé de comprendre pourquoi cela dysfonctionne. On apprend plus de ses échecs que de ses succès.
Aussi la réponse que vous me faites me semble un peu à coté de la plaque, elle dénote pour le moins d'un manque de curiosité personnelle ou pire d'une volonté à cacher les limites de sa compétence, est ce que je me trompe quelque part?
Raffou
 
Messages: 322
Inscription: Jeu 15 Mai 2014 18h17

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Hervé-P » Jeu 20 Avr 2017 20h55

— Si ma réponse semble (tu as bien dit “semble” !) être à côté de la plaque, c'est que, ayant justement plusieurs voies à explorer pour ce montage, je ne m'embête pas à essayer de comprendre. Je passe au suivant : ça évite bien des “prises de tête” !
— Je vais justement expérimenter le deuxième schéma, celui avec le transistor-inverseur BC327, celui que je n'ai pas encore expérimenté.
— Pour la bobine, j'en ai fait une en fil de Litz que je n'ai pas encore expérimenté. Mais avant, j'en ferai une autre avec plusieurs fils en parallèle, au lieu du fil de Ø 1mm, pour la bobine actuelle.
— Mon schéma actuel fonctionne, mais je suis limité à 1 A, même avec Rsc à 0,015 ohms et quand je règle la tension, il “chuinte”… Je vais remplacer aussi mes transistors japonais par des BC327/337 et mettre des diodes 1N5819 à la place des 1N4148…
— On verra bien si une des options fonctionne…
— EDIT : Pour l'instant, j'ai gardé tout comme tel, mais j'ai modifié certaines choses…
* Alimentation de la polarisation du MOS-FET canal P (collecteur du bipolaire NPN et résistance 330 ohms) par le + direct, avant Rsc (le “chuintement” a disparu) :
Schéma Alim variable B.jpg
Schéma Alim variable B.jpg (48.99 Kio) Vu 496 fois

* Essais de plusieurs condensateurs Ct (la bobine fait 80 µH), la valeur ~560 pF semble convenir.
— Pour l'instant, j'atteins 19V et 1,15A avant réduction parce que ça chauffe un peu (Les MOS-FET ont en effet un coefficient de température positif, contrairement aux bipolaires. C'est pour ça qu'on peut les mettre directement en parallèle !) ! Mais il me faut poursuivre… Je vais voir avec des MOS-FET 50N06 et 50P06, si j'arrive à en trouver, ou des équivalents : mes MOS-FET sont trop faibles !
— “Chi va piano va lontano” ! “Ti lamp' ti lamp' grand bobèche” !
— Cordialement !
Dernière édition par Hervé-P le Dim 23 Avr 2017 20h14, édité 1 fois.
Image Ruse de Sioux : “Ne cherchez surtout pas à compliquer des choses simples !”
Hervé-P
 
Messages: 81
Inscription: Ven 10 Fév 2017 15h36
Localisation: Sainte-Marie (Île de la Réunion)

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Raffou » Dim 23 Avr 2017 15h59

Hervé-P a écrit: j'ai pris des “borniers” de sortie haut-parleur de chaîne Hi-Fi pour y brancher des fils directement, comme j'en ai vu sur le Net.!

Voici plutôt ce que l'on trouve sur le net pour moins de 10€.
Il manque cependant le -5 volts, disparu depuis la release 1.3 de la norme ATX en 2005 bien que son emplacement soit resté libre sur le connecteur Mini-Fit Jr Molex:

Image

Image
Raffou
 
Messages: 322
Inscription: Jeu 15 Mai 2014 18h17

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar minirocker » Dim 23 Avr 2017 17h50

Bonjour à vous tous !

Génial ce petit circuit qui permet de réaliser directement une alimentation de base pour équiper un labo à partir d'une alime de PC ATX sans modifier celle-ci !
Sur quel site web l'avez-vous trouvé ?

Cordialement.
Eric.
minirocker
 
Messages: 194
Inscription: Mer 9 Déc 2015 12h12

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar DOMI du 64 » Dim 23 Avr 2017 18h51

bjr,
il suffit de demander à "google"!
http://www.ebay.com/itm/24Pins-ATX-Benc ... 2194399981

En effet pour tester ou carrément faire une alim à tensions fixes c'est intéressant!
cdlt
domi
DOMI du 64
 
Messages: 1020
Inscription: Ven 29 Oct 2010 13h58

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar minirocker » Dim 23 Avr 2017 19h31

Merci beaucoup pour le lien. Cela peut être utile pour se faire une alime de labo vite faite sur le gaz. 8)
Je vais voir pour en commander au moins 2 mais j'ai surtout des potes modélistes dronistes qui seront également intéressés pour alimenter leurs chargeurs d'accus.

Bonne soirée et bon bricolage !
Eric.
minirocker
 
Messages: 194
Inscription: Mer 9 Déc 2015 12h12

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Raffou » Dim 23 Avr 2017 20h51

Rechercher plutôt directement sur eBay avec les mots clef "ATX breakout (board, module)" et avec les critères suivants:
· Provenance = "Monde entier",
· Trier = "Prix + Livraison : les moins chers".
Le premier prix est actuellement à 6€98 (port inclus) chez un vendeur chinois et à 7€11 (port inclus) chez un vendeur de Hong-Kong.
Malgré les quelques centimes de différence, les vendeurs basés sur Hong-Kong ont ma préférence car le matériel acheté arrive souvent sous une dizaine de jours alors qu'il faut attendre un mois et parfois plus avec la Chine continentale.
Raffou
 
Messages: 322
Inscription: Jeu 15 Mai 2014 18h17

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Hervé-P » Dim 23 Avr 2017 21h03

— Cette carte nécessite de garder au moins la nappe et la prise du connecteur ATX de la carte-mère, en 20 ou 24 broches ! Pour ma part, vu la récup' dont je dispose, j'avais dessoudé tous les fils de toutes les nappes de mon alim' de PC et n'ai ressoudé que ce que j'avais besoin, soit le 5V et le 12V. J'ai aussi ressoudé une prise, la prise 4 broches du processeur de la carte-mère, en récupérant la prise-socle sur une carte-mère défectueuse pour en équiper l'extension d'alimentation variable !
— Les borniers de haut-parleurs de chaînes Hi-Fi ont cet avantage de pouvoir connecteur rapidement des fils sans prise spéciale, dont on ne dipose pas toujours. C'est pour ça que j'ai retenu cette solution pour mon alim' !
— À moins qu'on puisse dévisser les cabochons colorés de cette magnifique carte pour y glisser un fil dans un trou et de le coincer par l'“écrou” plastique de la prise !?… Mais il faudrait déjà raccourcir les fils de la prise ATX 20 ou 24 broches (les deux peuvent s'y brancher !) pour que ça reste d'un encombrement raisonnable…
— Voici la carte de mon alim' 200W qui fonctionne et que j'équipe (tous les fils, sauf le vert et un noir – PS-ON – sont dessoudés !) :
Alim ATX.jpg

Mais il a fallu faire une révision générale, avant de la remettre dans son boîtier ! Parmi les améliorations :
* Montage d'un filtre secteur constitué d'une self en mode commun et de deux condensateurs X2 (pas présents au départ) : un de 0,22µ et un de 0,1µ, pour éviter d'injecter les résidus de découpage sur le secteur !
* Remplacement de deux diodes montées sur une tôle pour le +12V par une double diode Schottky en boîtier TO220 :
diode.jpg
diode.jpg (27.26 Kio) Vu 435 fois

* Montage de prises pour pouvoir y adjoindre le module variable et pouvoir le démonter à volonté pour modifications, vu qu'il est toujours en expérimentation !
* Montage d'un volt-ampèremètre chinois à affichage LED pour la tension variable,
* Montage de deux LEDs sur le 5VSB et le PG pour visualiser l'état de l"alim' !
— “Mine de rien”, c'est du boulot ! Je n'ai pas eu de trop d'une “boîte à ampoules” (à mettre en série avec le montage 220V à tester !) pour la tester “dans tous ses recoins”, cette alim' ! Il y a eu aussi de la découpe dans la tôle du boîtier pour y adjoindre :
* le petit interrupteur branché entre PS-ON et la masse,
* le potentiomètre 20k pour l'alimentation variable,
* le voltmètre-ampèremètre chinois,
* les prises de sortie 5V et 12V,
* une prise HP DIN pour la sortie variable (J'aime bien ces prises !).
— Les deux diodes 3mm sont entrées de force dans une des ouïes de ventilation (que je souhaite laisser ouvertes après collage d'une face avant) et collées à la colle thermofusible.
— Voili-voilou ! Quand l'alimentation variable marchera correctement, je referai un “topo” plus complet !
— Après moult recherches, j'ai enfin trouvé sur aliexpress, à des prix défiant toute concurrence, des MOS-FETs complémentaires 47P06 et 50N06 ! Ça devrait convenir, vu qu'ils sont presque équivalents à l'IRFZ44 !
— Cordialement !
Dernière édition par Hervé-P le Dim 7 Mai 2017 15h37, édité 1 fois.
Image Ruse de Sioux : “Ne cherchez surtout pas à compliquer des choses simples !”
Hervé-P
 
Messages: 81
Inscription: Ven 10 Fév 2017 15h36
Localisation: Sainte-Marie (Île de la Réunion)

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Hervé-P » Dim 7 Mai 2017 15h12

— Rebonjour.
— Pour l'instant, ayant essayé le transistor BC327 pour alimenter le MOS-FET canal N à travers le +12V direct, je n'ai pas obtenu le fonctionnement espéré : trop faible intensité ! Je reste donc sur le premier schéma, celui que j'ai posté en premier : c'est celui qui fonctionne le mieux !
— Mais j'envisage une autre voie : rendre cette alimentation totalement variable ! D'après ce schéma :
s_atx01ad.jpg

, j'ai pu extraire le schéma de celle que je possède, étant donné qu'elle n'est pas tout-à-fait la même (variantes en bleu, modifs en orange, modifications futures en gris et vert – C'est bien celle de la photo du PCB dans mon précédent post !) :
Schéma Alim ATX.jpg
Par “économie de bouts de chandelle”, ces “Indiens” n'avaient pas monté le filtre d'entrée secteur ! De plus, ils avaient monté deux diodes FR302 sur une tôle pour le +12V, que je me suis empressé de remplacer par une double diode S16C40 (16A, 40V) !!! Vive la récup' !

— Modifications envisagées, de haut en bas et de de gauche à droite :
* Suppression de la résistance de 22 ohms et de la diode FR102 et (remplacement de la 1N4148 de l'alimentation du TL494 par celle-ci… heu… C'est déjà fait !) (** Pas nécessaire : la tension +12V ne montant “que” jusqu'à 28,8V et le TL494 supportant jusqu'à 42V, ce n'est pas nécessaire de les enlever !),
* Montage d'un potentiomètre de 10k entre Vref, broche 2 et masse pour rendre les tensions variables, toutes les tensions à la fois !
* Suppression de la protection en surtension de toutes les tensions (Sinon, remplacement de la Zéner C3-5 – 5V par une 12V voire 15V ?),
* Suppression des tensions -12V, -12VX et -5V,
* Suppression de la commande de ventilation (à brancher sur le +9V de l'alimentation +5VSB – remplacement du condensateur de 47µ par un 100µ voire 220µ ?),
* Condensateurs de 2200µ/35V sur le +12V, 1000µ/16V sur le +5V et garder le 1000µ/10V sur le +3,3V…
— EDIT : je garde le pont de résistances branché sur la broche 1 du TL494, mais je pense rendre une de ces résistances variable (celle du +5V à remplacer par un 10k ajustable ?) pour ajuster le +5V à maxi 12V. Ce qui porterait le 12V à 28,8V et le 3,3V à 7,92V.
— EDIT2 : Je pensais supprimer le LM393, mais il y a la détection de courant par la 100k branchée au petit enroulement détecteur de courant sur le transfo de modulation… Et si je branchais le PG sur le +5VSB, via la résistance de 2k2, au lieu du +5V, maintenant variable ?
— Je vous demanderai donc de vérifier si les modifs envisagées sont valables et de me diriger dans mon travail.
— Merci d'avance et cordialement !
Image Ruse de Sioux : “Ne cherchez surtout pas à compliquer des choses simples !”
Hervé-P
 
Messages: 81
Inscription: Ven 10 Fév 2017 15h36
Localisation: Sainte-Marie (Île de la Réunion)

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Hervé-P » Mar 16 Mai 2017 17h08

— Re-rebonjour !
— Pour ce qui est de la modification de ma précédente alimentation, j'ai trouvé plus simple ! Une alimentation 400W, du type XCESS(USA) - ATX2-03-400XA qui se prête à merveille pour une modification “en profondeur” !
— Cette alimentation, la voici :
alim 400W.jpg

— Et voici son schéma, que personnellement, je n'ai pas trouvé sur Internet :
Schéma alim 400W.jpg

— Vous remarquerez tout de suite qu'il y a certains composants en gris, d'autres en rouge et d'autres en vert… Pour ceux en noir, on n'y touche pas, ni ceux en rouge. Pour les deux résistances en vert, on les remplace par un potentiomètre 10 k linéaire. Ceux en gris, “débarras par le vide” : on les enlève tous !
— Voici donc la platine débarrassée de tous ces composants en gris sur le schéma :
Modifications.jpg
“Débarras par le vide” de pas mal de composants et modifications en noir.

— Les zones entourées de couleur appellent quelques précisions :
* Rouge : le circuit de protection anti-surtensions et sous-tensions,
* Gris foncé : le circuit PG,
* Bleu : le -12V,
* Blanc : le -5V,
* Orange : le 3,3V.
‑ Là, on ne lésine pas : on enlève tout ! Cependant, j'ai procédé par étapes :
* En haut de la zone rouge : une diode et une résistance. Essais : OK !
* Puis enlèvement de tout le circuit de protection. Essais : OK !
* Enlèvement du 3,3V, du -5V et du -12V. Essais : OK !
* Enlèvement de tout le circuit PG. Essais : OK !
— Pour l'instant, je n'ai pas touché aux deux résistances en vert. Puis on modifie certaines valeurs :
* Condensateur 1000µ 16V sur le +12V : remplacé par un 2200µ 35V,
* De même pour les deux 1000µ 10V sur le +5V : remplacés par un 470µ 16V et un 1000µ 16V,
* Le 47µ 50V du + 17,5V d'alimentation du TL494 a été remplacé par un 100µ 25V
— La double diode du +12V, les 2 condensateurs et les 2 résistances appellent un commentaire. J'essayais sur des lampes 12V 15W en série sur le +12V (et une seule sur le +5V), une fois remplacé les 2 résistances en vert par un potentiomètre 10k linéaire. Devant l'imposibilité de monter en tension suite à essais sur boîte à ampoules de 105W total, j'enlève les 2 ampoules du +12V et je monte en tension… Las ! La double diode du +12V que j'avais pris soin de remplacer par la double diode du +3,3V (une S20C40 – 20A 40V !) “claque” sans crier gare : court-circuit total ! Alors, j'avise de monter une double-diode 60V 30A (qui peut le plus, peut le moins !) non sans modifier le circuit “snubber” monté en simple exemplaire en parallèle sur les deux sorties 12V (une résistance 15 ohms et un condensateur céramique 1 nF !)… M'inspirant de ce qui existe sur le +5V (4,7 ohms et 10 nF), je monte alors deux résistances de 15 ohms et deux condensateurs 10nF 100V en parallèle sur CHAQUE diode. Re-essais avec des lampes moins puissantes : une de 12V 5W sur le +5V et deux de 12V 4W en série sur le +12V. Essai concluant !
…/…
Dernière édition par Hervé-P le Mar 16 Mai 2017 17h33, édité 1 fois.
Image Ruse de Sioux : “Ne cherchez surtout pas à compliquer des choses simples !”
Hervé-P
 
Messages: 81
Inscription: Ven 10 Fév 2017 15h36
Localisation: Sainte-Marie (Île de la Réunion)

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Hervé-P » Mar 16 Mai 2017 17h20

— Suite :
— Voici des photos des essais :
20170518_123938.jpg
Alimentation branchée mais pas encore démarrée (PS-ON ouvert).

— J'y ai branché deux module chinois volt/ampèremètres, très pratiques pour ça. L'alimentation est branchée sur le secteur mais pas encore démarrée (L'interrupteur PS-ON est ouvert !). Les LEDs des volt/ampèremètres sont branchées sur le +5V SB, ce qui fait office de témoin Stand-By ! Pour ce qui est d'un voyant “Marche” (LED verte), je pense le brancher sur l'alimentation 17,5V du TL494, broche 12 (entre le transistor et la résistance de 22 ohms – une LED avec une résistance 1k à 2k2 en série, suivant rendement de la LED) car le circuit PS-ON coupe et établit l'alimentation du TL494 sur ce modèle.
20170518_124021.jpg
Alimentation démarrée. Tension moyenne.

— Fermeture de l'interrupteur PS-ON. Montée en tension moyenne (comme si pas modifiée). Essais concluants !
20170518_124050.jpg
Tension maximum !

— Montée en tension maximum. Pas de problèmes ! Sur ces essais, j'ai branché un potentiomètre marqué 4,7k mais sa valeur dépasse les 5k6. Malgré ça, ça marche “au poil” !
— EDIT : Je vais voir aussi pour la limitation d'intensité. Une alim' de 400W, ça ne rigole pas !
*** Pour ce réglage d'intensité et limitation, comme mes volt/ampèremètres chinois sont limités à 10A, je pense me servir de leurs shunts comme résistance série de très faible valeur (Ça tombe bien : ils sont branchés sur le retrour négatif – entre le fil bleu et le noir. Comme ça, je peux les utiliser comme résistances série de limitation d'intensité !) Voici comment :
Réglage intensité.jpg

— Explications : le système de résistances, d'ajustable et de pot. de réglage se branche sur la broche 15 du TL494, avec un “snubber” sur la broche 3. Pour ce qui est du “sensor” de courant, pris sur les shunts des ampèremètres chinois, il se branche sur la broche 16. Quand une seule des sorties débite, l'intensité maximale de 10A sort par cette sortie (ces ampèremètres chinois sont en effet limités à 10A.). La tension de la broche 16 du TL494 est alors la moitié de la tension présente sur la sortie qui débite. Mais quand les 2 sorties débitent, la tension broche 16 s'élève alors à la somme des 2 tensions présentes sur les 2 sorties. Alors, l'intensité maximale se “partage” à la somme des intensités des 2 sorties, limitée à 10A ! Si bien que les sorties débitent l'une 7A, l'autre 3A, par exemple. Ce qui protège l'alimentation des débits excessifs. Avec 400W, il y a de la marge, mais je ne veux pas pousser cette alimentation dans ses retranchements : elle n'apprécierait pas !
— EDIT 2 : D'après ce que j'ai “déménagé” sur le circuit imprimé, il y aurait même la possibilité de rendre la sortie 0-10V symétrique ! Il suffirait de rajouter 2 diodes FR302 et 1 condensateur 1000µ 16V pour se servir de l'ex-sortie -5V, limitée toutefois à 3A ! À étudier, tiens !
— Si vous voulez la construire, n'hésitez surtout pas !
— Cordialement !
Image Ruse de Sioux : “Ne cherchez surtout pas à compliquer des choses simples !”
Hervé-P
 
Messages: 81
Inscription: Ven 10 Fév 2017 15h36
Localisation: Sainte-Marie (Île de la Réunion)

Re: Nouvelle vie pour une alim PC sauvée de la déchetterie

Messagepar Jean-Luc Coulon » Dim 21 Mai 2017 10h09

Bonjour,

Je voulais signaler un petit problème avec ces petits voltmètres-ampèremètres chinois.
La mesure de courant se fait sur le rail négatif.
Il y a donc un shunt sur ce rail. Ceci, en soi, ne pose pas de problème.

Mais l’alimentation a, le plus souvent, le pôle négatif à la terre. Ce qui ne pose pas non plus de problème.
Cependant, si le montage qui suit a aussi une borne de masse reliée à la terre, le shunt de l’ampèremètre se trouve court-circuité par la terre est devient inopérant.
On a le même problème si on fait des mesure sur le circuit connecté à l’alimentation avec un oscilloscope alimenté par le secteur, le plus souvent ces oscilloscopes ont la masse reliée à la terre, ce qui provoque le court-circuit indiqué.

Cela n’a pas vraiment de conséquence fâcheuse (dangereuse), seul le courant affiché par l’alimentation est nul ou proche de zéro.

Jean-Luc
Jean-Luc Coulon
 
Messages: 1
Inscription: Dim 21 Mai 2017 09h50

Précédente

Retourner vers Réalisations personnelles

Qui est en ligne

Utilisateurs parcourant ce forum: bthiry et 2 invités