Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Place à l'inventivité et à la créativité, à lampes... ou à transistors

Modérateur: Klara

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar ROGER33 » Sam 20 Juin 2015 10h57

voici le "vieux" montage de cette régulation du ventilateur. super génial pour se chauffer l'hiver :lol:
Roger33 parfois ne réfléchit pas trop. Mais après avoir monté ce truc surle transfo de ma vieille alim en rénovation...J'ai vite pigé qu'il fallait trouver plus malin... Pourtant, sur ma perruque (alimentée en 15/18 volts par une GROSSE alim variable... Cela "semblait" aller, Ben NON! :(
regul ventilo1.jpg

Le fil qui passe au dessus c'est le pot du réglage d'intensité du disjoncteur qui m'a donné des soucis. Sont pas finis d'ailleurs! Grrrr

A gauche tout en haut, la CTN qui assure la vitesse de débit du ventilo, c'est très progressif mais poubelle... Ça chauffe trop sous 30 Volts.
Voici ce que j'ai obtenu en commande proportionnelle moteur au ralenti
moteur au ralenti max.jpg

Et moteur à fond la caisse. Obligé de le lester, il voulait s'envoler
moteur a fond.jpg

Bon pas facile, la synchro avec un APN bon marché, mais on voit la différence
et voici le résultat :)
Gestion_ ventilo2.jpg

On voit ici un ventilo Paps assez important (3,4W et...il tourne au ralenti MAIS il est géré par un simple transistor BC 327 rikiki qui reste froid aussi bien au ralenti qu'à pleine vitesse!!! Roger est content. :)

Mais ici aussi, ce ne fut pas aussi simple que prévu. Pas le circuit, mais justement la sortie de la charge très inductive en fait. Au début j'en ai même fait griller...Un moteur de ventilo et un BD 135!
Le pauvre n'arrivait pas à écouler les électrons assez vite lors de son blocage, et sa jonction a fondu pendant que j'étais parti me régaler d'un canard à l'orange entre midi et 14 heures. j'ai remédié à cela.
Un jour c'est sur je vais refiler le feu a mon petit atelier. :lol: Mon alim était à fond (24Volts) la régulation de vitesse du ventilo au mini (c'est là où ca chauffe le plus) et j'avais oublié de régler le disjoncteur, donc ça a tourné, tourné jusqu'à fumer!
Dernière édition par ROGER33 le Sam 20 Juin 2015 11h46, édité 1 fois.
ROGER33
 
Messages: 1250
Inscription: Sam 30 Oct 2010 17h48
Localisation: Bordeaux

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar ROGER33 » Sam 20 Juin 2015 11h42

En effet, ces petits moteurs sont très inductifs comme tous les moteurs à induction.
Ceux à cristaux piézoélectrique c'est mieux... Mais BEAUCOUP plus chers! :wink:
Moteur ventilo.jpg

L'enroulement a tenu le coup, mais ni le pauvre BD 135 ni le Ci de gestion, les deux sont Out (la sonde a effet Hall(en haut le petit truc noir) est bonne, elle me servira peut être un jour...)
La cause la voila... Héhéhé Roger aurait dû s'en douter, il est trop confiant, ça le tuera.
Mauvaise charge.jpg

On voit très bien que lors de sa saturation tout va bien, il est très obéissant ce transistor, MAIS lors de son blocage... On voit aussi la tension sur le collecteur qui peine à dégringoler... Or la commande est bonne... C'est fait par deux Mos dans le CI et ils donnent soit du 12V, soit une masse quasi à zéro donc c'est la charge! La preuve? j'ai refilé une 22 Ohms à la place de la charge inductive et les signaux de commande étaient parfaits sur le collecteur. Bon, elle fumait beaucoup à fond mais c'est normal , 30V à 80% ça déménage.

Comme vous l'avez vu plus haut...j'y ai remédié par des ruses se sioux et mon transistor se régale à couper le jus en rondelles de saucisson sans jamais chauffer car il est ou saturé ou bloqué, donc y peut pas chauffer.(sauf si la charge est trop forte bien sur mais...C'est pas le cas.

J'ai donc remplacé cet ÉNORME transistor par un tout rikiki en boitier époxy TO 92 sans radiateur et... Ça roule! Enfin, ça tourne.
24H à fond, 24h au ralenti maxi, rien ne bouge ni ne chauffe, enfin juste un peu le moteur du ventilo si à fond, reste à ajouter ce petit montage sur la carte. :) encore un CI quelques résistances diodes et capa. Grrrr.

Comme y me restait des trigger en trop, j'en ai profité pour réaliser une commande de démarrage automatique Ça reste à l'arrêt si ça chauffe pas et démarre tout doux et si on insiste à tirer sur le ballast, la tornade blanche arrive c'est la madame qui est contente... Non, c'est le ballast qui respire un peu grâce à la brise légère qui lui caresse son radiateur. :wink:

Pour cette fonction TOUT va bien! Reste ce disjoncteur de malheur! Je vais chercher
Si quelqu'un a une idée géniale donc simple, je suis preneur.Là je peine. d'ici que je sois obligé de rajouter une "résistance" de 0,0002 Ohm pour simuler cette piste à résistance fantôme qui fait des miracles dans ce petit montage y a pas loin. Mais où que je vais trouver cela?
La vie est dure ne trouvez vous pas?
ROGER33
 
Messages: 1250
Inscription: Sam 30 Oct 2010 17h48
Localisation: Bordeaux

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar jmespe » Sam 20 Juin 2015 20h14

et un tlc271 avec un potar ?
Presse Papier-1.jpg


là, vous êtes sur d'avoir l'offset à zéro, mais il faut faire un réglage ...
jmespe
 
Messages: 1536
Inscription: Mar 11 Mai 2010 17h38
Localisation: PAU (64)

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar ROGER33 » Sam 20 Juin 2015 21h29

OUI c'est je pense LA solution Jmespe. MAIS pas que. D'une part ceci suppose deux boitiers au lieu d'un. Or sur ma carte y a du monde déjà. (en plus d'un sextruple trigger à ajouter pour le ventilo) mais bon c'est pas très important en bousculant un peu des trucs, ce que je suis entrain de faire..MAIS pas que car:

Héhéhé si vous avez suivi...Quand peu de courant, supposons que mon Ci dont l'entrée inverseuse a été fixée a 4mV via 750K et 100 Ohms à la louche voit une tension très faible (quelques mv se developper aux bornes du shunt sur son entrée non inverseuse...
Hop il est obéissant et bascule...(notez bien le pot de réglage d'intensité est au MAX de sensibilité. Donc vers la sortie du "shunt".)
MAIS à présent supposons qu'on tire 4 ampères héhéhé c'est LA ou j'ai des pb. On va avoir 250 ou 300 mV aux bornes du shunt donc il v falloir baisser ce niveau via le pot... MAIS le relais reste collé des 4 Amp et impossible de l'en empêcher...Même en CC du talon au + y veut rien savoir... C'est PAS normal mais c'est!
C'est pourquoi je tournais en rond car sur ma perruque ...Nickel

Pas sur que votre circuit ajustable ne réagisse pas pareil.... (j''essaierai, c'est très vite fait)

Quoi qu'il y ait au point froid du pot..(a la louche 150 Ohm).. ben oui car si en C/C plus de disjonction possible ... théoriquement
MAIS comme l'offset du bidule n'est pas réglable...je me suis fait piéger

Supposons ce circuit réglable que vous me proposez, il va basculer exactement a équipotentialité des entrées (en supposant) MAIS en fait il est a effet de champ et a ces minuscules tensions... il se passe des choses peu catholiques ... Essayez et vous le constaterez

ca va fonctionner peut être mais sans sécurité. Or cette fonction est essentielle pour la protection.

Voyons ma sottise de câblage qui rendais ce circuit de disjonction super souple!

J'ai mis du temps à piger certes, mais en fait, plus on tire et plus on modifie l'offset grace a cette erreur de raccordement, sinon comme VOUS (si j'ai bien pigé ce que vous avez écrit plus haut ) et probablement pour les mêmes raisons j'aurais dit: Ça peut pas marcher!
Comme quoi des fois, se gourer ou faire une erreur, ça aide!

C'est proportionnel au COURANT cette dérive de RV1par rapport a l'entrée du shunt donc on peut régler l'ampli Op au moyen de R5 / R4 pile poil pour qu'il bascule très vite aux faibles intensités et aux fortes.. c'est la tension appliquée par VR1 qui va déplacer l'offet grace... A la résistance de la piste qui la rends légèrement plus positive que la résistance R4... Ce qui permet un réglage bien plus souple et progressif Faut sous 4 amp que VR1 soit 30 a 35 mv plus positif que quand il n'y a pas ou presque pas de débit et là c'est vraiment plus progressif et sans danger. Ca bascule bien et ne colle pas intempestivement comme sur ma carte . Même en le chauffant comme en plein soleil ça bouge pas, j'ai fais des tests ce jour encore.

Faut donc enfin 0,009 Ohms entre l'entrée du positif et l'entrée du shunt. et là je retrouve les caractéristiques de ma perruque. OUFFF!
Nous trouverons bien un bout de fil de constantan pour faire cela en dia 1,5 mm faut même pas 1 cm.
Suffit de mettre le shunt, une lampe phare, ajuster a 4 ampère et mesurer 35mv aux bornes du bout de fil de constantan avant le shunt.

Ça reste simple et c'est pas la mer à boire. J'essaierai un TL081 et je crois avoir dans mes tiroirs deux ou trois TL 272 je crois mais il est double donc n'ira pas, je vais en commander quelques uns pour le fun. Le TL 081 lui aussi possède un réglage d'offset mais consomme plus que le TL 271 mais faut encore ajouter un circuit de plus.
Tient il les 32volts? Le TL071 je crois 36. Merci pour l'aide jmespe mais je vais faire ainsi pour commencer, ça devrait coller si le relais ne colle plus :lol:

Un dessin vaut mieux qu'un si long discours, sinon y vont encore se moquer
Correction.jpg

Bonne soirée. je file, on m'a fait des crêpes :wink:
Heureusement qu'il y a les femmes, pasque bon, les polarisations, l'offset hein Grrr!!!
Tout cela finira dans les vide grenier...Alors...
ROGER33
 
Messages: 1250
Inscription: Sam 30 Oct 2010 17h48
Localisation: Bordeaux

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar Bricolou85 » Dim 21 Juin 2015 02h32

Bonsoir à tous,

Roger, les crêpes étaient bonnes ?

C'est bien le schéma, mais on ne sait pas quelle est la bestiole utilisée, ou je l'ai raté dans la littérature :roll:

Sur ce schéma corrigé on a 30 V en entrée, sur l'ancien on avait 32 V.
Comment est alimenté l'ampli OP (ou comparateur ), s'il l'est par le 30~32 V et la masse, ses entrées sont à un potentiel voisin et son fonctionnement n'est peut-être pas vraiment garanti ( type ? ), on risque aussi d'atteindre les limites de tension d'alimentation.
De plus, ainsi que l'a dit Transistorix ( mais ça dépend encore du type ), il faudrait que la résistance vue de chaque entrée soit identique, ce qui permet d'équilibrer les courants dans ces deux entrées. Ici ces résistances sont ultra-faibles ou pas constantes, j'ajouterais bien une 47 k en série dans chaque entrée...
Encore une idée, je laisserais les 2 résistances de 0,035 et la 0,009 où elles sont, mais toute la partie ampli/comparateur je n'utiliserais pas des pistes pour la raccorder aux résistances mais des fils, c'est peut-être de là aussi que vient la différence entre proto et CI.
Un peu comme ça, même si c'est incomplet du fait du potentiomètre de 10 k qui est déporté :

Correction02.jpg

A suivre,
Patrick
RFL 6522 jusqu'au 31/12/17, EPR pas usé à donner à Noël.
Horreur des faux-culs, des lèche-culs et fervent adepte de St Thomas.
Bricolou85
 
Messages: 4696
Inscription: Jeu 11 Juil 2013 02h06
Localisation: St Magrelon des Endoufles

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar Bricolou85 » Dim 21 Juin 2015 07h04

Re,

ça m'a empêché de dormir ce truc...
Y-a quelque chose de pas logique dans le fonctionnement :( :
On compare une fraction du courant de sortie qu'on ajuste avec le potar avec une tension fixe.
Il me semble qu'il serait plus raisonnable de comparer le courant de sortie, donc la tension sur le shunt de 0,07 avec une tension ajustable.
Donc le potar devrait être placé sur l'autre entrée, de plus on pourrait même étalonner le potar vu que ça serait linéaire.
Limite de courant de sortie == position du potar.
Ce qui n'est pas du tout le cas avec ce montage.
Bon, c'est l'idée à appliquer, mais je vais me recoucher :D

Patrick
RFL 6522 jusqu'au 31/12/17, EPR pas usé à donner à Noël.
Horreur des faux-culs, des lèche-culs et fervent adepte de St Thomas.
Bricolou85
 
Messages: 4696
Inscription: Jeu 11 Juil 2013 02h06
Localisation: St Magrelon des Endoufles

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar Transistorix » Dim 21 Juin 2015 08h14

Bonjour,

Moi aussi je n'ai pas dormi, mais ce n'est pas pour la même raison.

Par exemple pour un 741 on a :
Input Offset voltage : 1mv Maxi 5mV
Input bias current : 50nA Maxi 500nA
Ce qui fait dans 5k (lorsque le réglage est au milieu) : 0,25mV maxi 2,5mV

Dans l'exemple, les erreurs inhérentes au 741 et à la façon dont il est utilisé sont dans l'ordre de grandeur de la précision que l'on cherche à avoir.

Certes, avec un 741 amélioré cela marche un peu mieux, mais comme dit Patrick la solution est peut être ailleurs.

Tx
Transistorix
 
Messages: 1465
Inscription: Dim 9 Déc 2012 10h59
Localisation: Groland des arvernes.

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar jmespe » Dim 21 Juin 2015 12h22

bonjour roger

euh ... des crêpes à 10 heures du soir , est-ce bien raisonnable ?

sinon, je pense à cette alim et je vois 2 autres pistes

1- augmenter le shunt ...
dans une alim régulée, si vous placez la régulation après le shunt, il n'y a pas de problème.
Avec un shunt aussi faible, vous maximisez la probabilité de problèmes

2- je pense soudain en voyant votre schéma, sur l'ntrée du shunt à gauche, il y a marqué +30V
avez vous pensé au limitations du mode commun dans les aop ??
ils ne peuvent pas mesurer des différences si les 2 entrées sont proches de la tension d'alim supérieure

cordialement
jmespe
 
Messages: 1536
Inscription: Mar 11 Mai 2010 17h38
Localisation: PAU (64)

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar ROGER33 » Dim 21 Juin 2015 18h47

Bonsoir à tous,

Roger, les crêpes étaient bonnes ?

Bof la pâte n’avait pas assez reposée, c’était du vite fait, pour me faire plaisir. J’ai rien dit mais j’ai pensé qu’il fallait que je remette tout cela sur les rails! Faut rien lâcher, sinon on est mort. :(

C'est bien le schéma, mais on ne sait pas quelle est la bestiole utilisée, ou je l'ai raté dans la littérature


je pense l’avoir dit, peu importe c’est un vulgaire TL 072 donc un ampli Op a entrées FET."Dit" à faible bruit.

Sur ce schéma corrigé on a 30 V en entrée, sur l'ancien on avait 32 V.


Je pense que la tension on s’en fiche! Pas un seul transfo d’alim ne donnera la même tension. Certains 15V d’autres 27V d’autres 34V… Du moment que la tension A VIDE ne dépasse pas la tension admissible par les AOP… Ils sont montés en différentiels et de ce que j’en ai mesuré… Ils s’en fichent pas mal. Ma référence de tension montée avec un AOP ne varie pas de 5mV entre 10V et 36Volts alim de l'AOP!
elle ne varie qu'en température ce qui est assez facile a rattraper avec une petite CTN placée au bon endroit :wink:

Ce montage DOIT fonctionner avec quasi n’importe quoi car il est surtout destiné à moderniser des vieilles alims dépassées techniquement, on doit conserver la boîte, le transfo, le pont ou les redresseurs et la carte doit fonctionner sans AUCUNE autre modif que le remplacement des vieux 3055 NPN par des TIP 2955 PNP ou mieux comme le 2N 4399. Ces machins ont un gain de 30 mini à 5 Amp IC donc dans ce montage 150 à 170 mA de courant de base suffisent pour obtenir une régulation super bonne. Un seul suffit pour plus de 150 W continu à 50°. Cela change bien des choses MAIS faut que ce fichu disjoncteur fonctionne super bien car la résistance interne d'une telle alim est proche de celle d'une batterie, ça rigole plus.

Comment est alimenté l'ampli OP (ou comparateur ), s'il l'est par le 30~32 V et la masse, ses entrées sont à un potentiel voisin et son fonctionnement n'est peut-être pas vraiment garanti ( type ? ), on risque aussi d'atteindre les limites de tension d'alimentation.


C’est le cas. Le TL 072 est alimenté par exemple en 26Volts …. Il mesure quoi?
Une tension de quelques mV autour de… 26Volts!

De plus, ainsi que l'a dit Transistorix ( mais ça dépend encore du type ), il faudrait que la résistance vue de chaque entrée soit identique, ce qui permet d'équilibrer les courants dans ces deux entrées. Ici ces résistances sont ultra-faibles ou pas constantes, j'ajouterais bien une 47 k en série dans chaque entrée…


Ceci est une remarque judicieuse. :wink: Par habitude, sur tous les AOP à FET que j’utilise (sauf bien sur dans les montage en Girator, filtres actif et filtres à trappe (notch filter) je refile en série sur les entrées 10 à 33 K car j’ai remarqué des choses étrange si l’impédance est très très basse sur ces entrées…

Cela fait ça surtout quand on utilise ces AOP à entrées FET en alimentation asymétrique (un + et un moins et basta) Par exemple, on si on descend trop la tension sur l’entrée inverseuse… Au lieu de passer à 1 en sortie …On repasse erratiquement à zéro. Avec des résistances en série, cela n’arrive quasi jamais MAIS arrive parfois sur certain amplis OP (à FET uniquement)
C’est piégeux et je me suis fait avoir de nombreuses fois!

Ici je n’ai pas pris ces précautions.
Pourquoi? Car je suis parti de la mesure bête de la DDP aux bornes du shunt… Et comme avec le montage dont vous avez le câblage EXACT cela fonctionnait PARFAITEMENT, aussi bien avec alim d’entrée sur 9V, 15V, 20V et 26V (le max à vide que peut me fournir mon alim d’essais), je ne me suis pas posé d’autres questions. J’ai juste pris une dizaine de TL072, les aient passé sur la perruque, les aient fait chauffer car j’avais des doutes vu les faibles tensions à mesurer et comme TOUT fonctionnait nickel… Pour moi… FINI.
Le réglage du pot n’est pas très linéaire car le pot n’est pas linéaire. Pour des tests de sensibilité du disjoncteur… C’est sans importance, enfin je le pense.

Encore une idée, je laisserais les 2 résistances de 0,035 et la 0,009 où elles sont, mais toute la partie ampli/comparateur je n'utiliserais pas des pistes pour la raccorder aux résistances mais des fils, c'est peut-être de là aussi que vient la différence entre proto et CI.


Regardez le plan dessiné à la main… Ce montage fonctionne parfaitement bien. Il est en tout point conforme au Shéma… Il est reproductible et fonctionne pareil à TOUS les coups… j’étais tellement paumé que j’en ai cablé deux sur carte d’essais semblables… Avec les composants récupérés sur la carte qui ne fonctionnait pas et là… TOUT fonctionne! j'y perdait mon latin!

En effet…il y a un truc en plus, un truc piégeux et vicieux, ce n’est pas intentionnel mais cela lui permet de bien fonctionner alors que sur ma carte définitive cela n’y est pas… C’est le hasard de cette piste et de ces 32 mV, donc comme cela fonctionne super bien ainsi, le but de mes interrogations ici auprès de vous était de m’aider à piger POURQUOI

Ca m'a empêché de dormir ce truc…

Vous n’êtes pas le seul!
Y-a quelque chose de pas logique dans le fonctionnement :( :

Ha?
On compare une fraction du courant de sortie qu'on ajuste avec le potar avec une tension fixe.


Non, on compare une TENSION variable aux bornes d’un shunt avec une tension fixe.

Il me semble qu'il serait plus raisonnable de comparer le courant de sortie, donc la tension sur le shunt de 0,07 avec une tension ajustable.

J’ai essayé , cela fonctionne mal. Oublions le COURANT svp, car en fait, on mesure des TENSIONS.
Un ampli Op ne sait pas faire autre chose, enfin je crois.

Donc le potar devrait être placé sur l'autre entrée, de plus on pourrait même étalonner le potar vu que ça serait linéaire.


Oui en théorie, pas en pratique, essayez … Car si vous décalez la tension d’offset sur l’entrée inverseuse votre potentiomètre doit jouer sur des mV, pas des Volts et de plus, cette tension devra être d’une stabilité absolue puisque ce sera la référence… Perso j’aime pas trop cela, même si en théorie je suis d’accord avec vous. Ce serait une solution. Pensez qu’une dérive de cette tension de référence de quelques mV…Va vous faire passer la disjonction de 2Amp à 8 Amp comme qui rigole!
Ou l’inverse suivant le sens de la dérive. Cela ne m’emballe pas.

y a juste 6 composants très basiques à souder, tentez mais avant lisez ce qui va suivre, car moi aussi ça mempêchait de dormir, je pense avoir définitivement pigé.

Merci cependant pour l’aide.
ROGER33
 
Messages: 1250
Inscription: Sam 30 Oct 2010 17h48
Localisation: Bordeaux

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar ROGER33 » Dim 21 Juin 2015 19h00

bonjour roger
euh ... des crêpes à 10 heures du soir , est-ce bien raisonnable ?

Bonjour Jmespe :wink:
Y a pas d’heure pour du plaisir de déguster ces crêpes chaudes, craquantes mais moelleuses, fourrées de confiture de groseilles trempées dans du café au lait! Y a pas d’heure quand on est comme moi, gourmand.

sinon, je pense à cette alim et je vois 2 autres pistes
1- augmenter le shunt ...
dans une alim régulée, si vous placez la régulation après le shunt, il n'y a pas de problème.
Avec un shunt aussi faible, vous maximisez la probabilité de problèmes

Comme vous avez reçu ce schéma sur demande, vous avez du voir que c’est le cas, le shunt est bien sur AVANT la régulation et sur le positif, pas sur la masse.
Vous pouvez augmenter autant que vous le voulez ce shunt, mettre 2 Ohms, cela ne change RIEN!
Je l’ai fait car c’est très très vite fait sur perruque comme sur PCB définitif.

2- je pense soudain en voyant votre schéma, sur l'ntrée du shunt à gauche, il y a marqué +30V
avez vous pensé au limitations du mode commun dans les aop ??


Non je ne m’en suis pas inquieté du tout. J’ai juste regardé la tension max autorisée ils disent +/- 18Volts donc en assymetrique 36 volts, doit aller. J’ai donc avant toute choses pris deux alims alim 12V fixe en serie puis refilée en série une alim variable qui grimpe à 26V j’avais donc 36 Volts j’ai branché avec un milliamperemetre. En serie sur calibre 300 mA…rien, sur 30mA 4 ma, sur 40V 5,6mA mais ça tiens. Cependant ça chauffe au bout d’une heure car dedans y a une source de courant constant simplifiée (un fet et une zener) dont je ne connais pas la tension, donc ça n’aime pas trop de telles tensions, cependant ça ne claque pas. Je ne l’ai testé que sur 3 TL072 pas la peine plus car moi je ne dépasserai pas au pire 32V + 4volts sur UN circuit, les autres seront au max sous 32/34 Volts suivant les transfos utilisés...

ils ne peuvent pas mesurer des différences si les 2 entrées sont proches de la tension d'alim supérieure

Je pense que c’est vrai sauf que moi, mon montage est à maxi 380mV de la tension d’alim (sous intensité de 4 Amp environ) et mini 4mV de la tension d’alim et… Que ça fonctionne parfaitement bien... Avec plus d’une douzaine d’echantillons testés en réel. Donc ce n’est probablement pas la CAUSE.

J’aimerais cependant que vous m’expliquiez via mail le Pb dont vous avez parlé ayant necessité l’usage d’un circuit intégré un peu particulier… Je crois que c’est le même problème que moi.
A présent et j’en aurai terminé j’explique POURQUOI ça fonctionne car je pense avoir trouvé.
J’en ai deja parlé plus haut mais je résume et on passera à autre chose …

Faut regarder ou imprimer le dernier morceau de schéma archi simple que j’ai mit ici pour suivre.

Déjà, ajuster l’offset au quart de poil à l’aide d’un AOP le permettant… Ne sers à rien! Cela va affiner le seuil, mais le problème restera entier.

Augmenter le Shunt? Pareil, y aura plus de tension donc la disjonction sera bien plus sensible OK, MAIS pour les forts courants, le curseur du pot de 10k sera à fond vers la 100 Ohms en serie avec la variable de 100 Ohms (j’aurais pu mettre une résistance variable talon de 220 Ohms, c’est pareil.)

Dès que ceci est fait… L’ AOP passe à zéro, donc il commande le relais et coupe donc la sortie. :(
C’est cela mon Pb. Or NORMALEMENT, il ne doit pas se comporter ainsi.
Mais c’est ce que l’on constate. Point. Inutile d’en discuter, c’est ce que l’on CONSTATE sur des dizaines d’AOP semblables.

Donc suivez bien… Dans ce dernier montage très très semblable au précédent et dont vous avez le schéma et qui est aussi sur ce forum… Une résistance ridicule de 0,009 Ohm a été ajoutée… Sous 5 Amp de debit, elle développe une DDP d’environ 32mV… OR la résistance talon n’est plus à l’entrée du shunt mais à l’entrée de cette "resistance" ce point est donc PLUS positif de 32 mV que … L’endroit où est raccordé la 100 Ohms du pont qui fixe l’offset de l’entrée inverseuse. Héhéhé, DONC en fait, l’offset va BOUGER dans le sens qui va bien au fur et à mesure de l’augmentation du courant consommé! Ca se fait TOUT SEUL c’est pourquoi l’AOP ne perd plus les pédales et c’est pourquoi mon montage definitif refusait de fonctionner car lui, n’a PAS cette foutu micro résistance!

J’espère que vous avez pigé aussi, mais c’est pas simple. Au début je tournais en rond. Sans le savoir, en faisant cette bourde de câblage sur une piste longue, j’me suis sorti d’un sacré boxon pas facile simplement à solutionner.

Ca fait un peu bricolo mais ça fonctionne et très bien, donc on va passer à autre chose.
Pas envie de saouler les gens avec cela. :wink:

J’aimerais cependant Jmespe que vous m’expliquiez ce Pb dont vous avez parlé sur un contrôle de charge de panneaux, ça m’intéresse, si vous le voulez bien sur. Je suis presque certain que votre truc avait le même Pb que moi! En fait j’ai eu du bol car je ne pense pas que j’aurai eu cette idée de rendre l’offset variable devant ce Pb.
Y reste des crêpes…
Merci à ceux qui ont tenté de m’aider. :)

Ps: z'avez vu cette régulation de ventilo? Normalement cela ne peut pas fonctioonner car le transistor est prévu pour 600mW max or le moteur consomme 3W2 c'est écrit dessus! Ben si! Ca marche et y a bien 12Volts aux bornes!
Là aussi c'est marrant à constater. J'en suis le premier surpris. Ils doivent mesurer cela en dissipation continue toute bête...là , la jonction a un petit temps de repos... ça lui suffit pour même pas chauffer mais il est vraiment petit à fond ce repos! Mais ça tiens. Chance. J'ai pas osé mettre un 0,2W :lol:
ROGER33
 
Messages: 1250
Inscription: Sam 30 Oct 2010 17h48
Localisation: Bordeaux

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar jmespe » Dim 21 Juin 2015 19h30

bonjour roger

mmm donc pour le tl072 dont la doc est ici :
http://www.ti.com/lit/ds/symlink/tl072.pdf

voici la ligne qui est interressante

Vicr:
Presse Papier-1.jpg


le mini garanti est 11V pour une alim indiquée en haut du tableau à +/-15V
seul le "typ" peut aller jusqu'à 15V
joli contournement (!!) pour indiquer que votre shunt avec une tension de 0.480 en dessous de l'alim (+)
n'est pas garanti

mais effectivement, à distance je ne peux rien garantir
c'est vous qui connaissez ce que vous avez mesuré !

Pour info, je suis tombé moi aussi sur une petite bizarrerie
La rampe pour mon ana de spectre , hein, la rampe de 0 à 5 V ;
Un aop en ampli suiveur (quoi de plus simple)
hé bien plaf, au bas de la rampe, monsieur ne suit pas
et au lieu de saturer à zéro plus Vcesat , il sature à l'alim positive !!

Pour mon montage de compteur solaire (moi je voulais mesurer la tension du shunt, pas juste la comparer)
c'est ici en bas :
http://jmespe.free.fr/electro/realisation/index.html

regardez surtout la deuxième version :
http://jmespe.free.fr/electro/realisati ... index.html

le ci est un max4376 (un peu rare)
le µ tourne à 32K (conso mini)
et j'ai programmé en assembleur toutes les op arithmétiques (multiplications 4 chiffre pour la puissance, soustraction pour la loi des noeuds...)

un montage pour vou inspirer pourrait être celui là:
current_sense.gif
current_sense.gif (3.71 Kio) Vu 671 fois


en remplaçant bien sur les condo c3 et c4 par des res

cordialement
jmespe
 
Messages: 1536
Inscription: Mar 11 Mai 2010 17h38
Localisation: PAU (64)

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar ROGER33 » Dim 21 Juin 2015 20h18

le mini garanti est 11V pour une alim indiquée en haut du tableau à +/-15V
seul le "typ" peut aller jusqu'à 15V

oui mais ca fonctionne tres bien... donc

joli contournement (!!) pour indiquer que votre shunt avec une tension de 0.480 en dessous de l'alim (+)
n'est pas garanti

je ne pige pas, je ne contourne rien.
Je dis: Si pas de courant, le pot est vers 10K et l'offset est donc fixée a ici env 4mv...l'ampli Op fonctionne parfaitement...Sur certain faut 560k pour un peu plus d'offset c'est tout, car ils ne sont pas ajustables.

Je dis: Quand l'intensité monte, on diminue la sensibilité pour que cela ne disjoncte pas, la resistance de 100 Ohms du pont de l'entrée inverseuse voit sa tension DIMINUER au fur et à mesure du débit.
Donc je precise: C'est cela qui fait bouger l'offset. Donc...ça fonctionne!
Et cela effectivement... se mesure.
C'est tout.
Merci, je vais regarder cela en detail.
Dernière édition par ROGER33 le Dim 21 Juin 2015 21h05, édité 1 fois.
ROGER33
 
Messages: 1250
Inscription: Sam 30 Oct 2010 17h48
Localisation: Bordeaux

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar jmespe » Dim 21 Juin 2015 20h52

hé hé :
"je ne pige pas, je ne contourne rien"

vous non, mais le datasheet annonce en première page dans le chapitre 1 "features"

en dernière ligne
"common mode input voltage include Vcc+"

c'est donc faux , ce qui est garanti c'est Vcc+ -4 V ... tout de même !
jmespe
 
Messages: 1536
Inscription: Mar 11 Mai 2010 17h38
Localisation: PAU (64)

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar ROGER33 » Dim 21 Juin 2015 21h44

Un aop en ampli suiveur (quoi de plus simple)
hé bien plaf, au bas de la rampe, monsieur ne suit pas
et au lieu de saturer à zéro plus Vcesat , il sature à l'alim positive !!

Hahaha bienvenue au club, c'est quoi comme AOP? Des à entrées fet?
vous non, mais le datasheet annonce en première page dans le chapitre 1 "features"


Ha oui ils ne prennent pas de risques en écrivant cela . Moi je mesure moi même quand trucs speciaux, je ne fais pas confiance à ces papiers. Cela ne coûte rien d'essayer, heureusement, les fabricants mettent encore les schémas internes,( enfin certains!) donc on peut se faire une idée.
Ne pas oublier que les ricains sont TRES procéduriers, donc les boites ne se mouillent pas trop dès fois que. Très souvent leurs produits sont bien plus stables et performants que les datasheet ne le précisent.
Là-bas y doit y avoir un avocat pour 500 habitants! :lol:

Pour le TL072 on a quand même une perte de 1,2V facile (au plus comme au moins), c'est normal vu l'étage de sortie. Avec certains Aop l'une des branches sort en direct, on s'arrange pour l'utiliser.

Pour l'offset, ceux que j'ai, broches 1.2.3 sont super bien ajustés (au laser probablement) mais l'autre coté 5.6.7 c'est plus de 5mV facile et je m'en suis aperçu à mon grand étonnement, pour faire des amplis et autres machins classique on s'en fiche mais j'avais jamais tenté de mesurer des tensions aussi faibles, aussi j'ai modifié mon implantation pour utiliser ce coté dans cette fonction un peu tordue. Sur 87 (deux barettes presque pleine j'en ai 82 qui sont impec pour cette fonction dont la moitié a peine 1,3mV
pour l'amateur c'est bien suffisant.

J'ai regardé votre plan, un ampli Op micropower doit faire le job
Pas un TL062 mais il y en a qui devraient aller, surtout les amplis Op pour gérer les elements d'accus Li Po et Li Ion. il ne consomment rien mais je ne sais s'ils sont bien linéaires

Faut se méfier chez Maxim, ils sortent des trucs de ouf mais après pour en recommander... J'utilise des MAX 146 (des Can 12 Bits multiplexés) et les décodeurs qui vont bien avec ...Leur prix a doublé et même plus en 5ans et en plus, rares les décodeurs, j'me suis depanné en Israel sinon délais de ouf!
Mais bon , ils font de bons circuits. Pour les references de tension je prends de 2,5V de analog device ils sont très facile à trier et ne bougent pas.
bonne soirée.
ROGER33
 
Messages: 1250
Inscription: Sam 30 Oct 2010 17h48
Localisation: Bordeaux

Re: Alim variable 0/25 V disjonction 30mA/4Amp ajustable

Messagepar ROGER33 » Ven 10 Juil 2015 12h32

Bon ben ...
ANE !.jpg
ANE !.jpg (36.55 Kio) Vu 597 fois

En effet, hier je me suis remis sur ce projet, optimisé tout comme il faut, rien ne chauffe, je vais de 5 a 15V suivant température démarrage automatique à 30°C progression jusqu'à 60°C avec limitation a 15V automatique (on a pitié du moteur du ventilo) et que ce soit au ralenti ou à fond, les transistors restent froids. :D
Ne pouvant passer ma nuit à tester la fiabilité de ce machin "génial", je refile une bascule lente pour régime mini et régime à fond... Et laisse tourner (On ne sait jamais!)

Ce matin j'arrive...TOUT va bien tout est resté froid sauf que... Je désirais écouter la BBC pour tenter de piger ce que pense les "anglois," maitres de la finance mondiale (+ de 40% des transactions mondiales passent par Londres) de cette "crise" grecque... Je commute mon transistor en GO (LW) et là!....

Aie Aie Aie la CATASTROPHE! Projet de régulation magique à oublier :twisted: C'est plus une super alim avec ce truc ajouté, c'est aussi un générateur variable toutes bandes en prime! :lol:

Donc j'ai coiffé mon bonnet d'âne et vais pour la régulation de vitesse en rester à mon bon vieux schéma analogique! (je m'en sers pour la régulation de température de quartz surtout mais ça peut servir à d'autres choses) Tant pis, y aura un ou deux transistors de puissance pour le ballast et un autre sur le même radiateur. Ça tombe bien, car s'il chauffe, il s'auto ventilera! :)
Dès fois on ne devrait pas trop se compliquer la vie...(mais une vie pas compliquée c'est pas vraiment vivre...Hihihi, juste exister.)
Bon, j'y retourne, faut finir ce machin à présent Grrr.... Ça fait désordre
ROGER33
 
Messages: 1250
Inscription: Sam 30 Oct 2010 17h48
Localisation: Bordeaux

PrécédenteSuivante

Retourner vers Réalisations personnelles

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité